Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Account issues?

I am using API with PyViCare lib to gather data from my heat pump.
Recently, during the weekend, it completely stopped working. It seem not to be caused by reaching api calls limit (had < 2k monthly). Tried to configure vitoconnect + api client from scratch but this ends up in some vitoconnect reboots just after it tries to send some heat pump data to server after successful connect.
Called local support but their only advice was to buy new Vitoconnect device which at this point sound ridiculous. 
Any chance that someone will look into logs/my account (My vitoconnect serial is: 7571381664282103) if something needs to be pushed?:)

Described that also in:


Hi @przygod, is this issue still relevant? From your other thread I can see that it should be solved.


Best regards,



Hello @MichaelHanna 
Well, yes and no 🙂
No  - since the issue is solved by support for now after completely resetting my account.
Yes - since i don't have idea what caused that and how to avoid same story in the future. Not sure if some api calls might cause that (but i just query for temperature and seem not to reach limits)?

So it happened again (and again on weekend if that changes anything).

Vitoconnect keeps rebooting after trying initial send (it successful connects to heatpump, then to wifi and connects to server...and after some seconds its got rebooted). 

Again seem not to be the issue with vittoconnect device but rather some account/server issues (device don't get rebooted at all if not connected to server).

Anyone can help or investigate if that is caused by any API use which is also running on the same account (just simple reads of temperatures) or I just should give up with this device assuming that Viessman cant fix that?

Calling to service every two weeks just to reset account is waste of time... 

Anyone can help?

Hi @przygod , sorry for the late reply. Since you are located in Poland, you would need to get in touch with the Viessmann service from Poland. They could support you here and if it is a deeper technical issue create a ticket towards the IT.

I assume you are already in contact with the service colleagues. Otherwise let me know if you need a contact.



Tried to get some help from local support in Poland but sadly there was no response for many days.

From the topic above we clearly see that issue is somewhere in software/Viessman servers (when you reset account + device it works like a charm....but only for some time...until server again will decide to kick you for some unknown reason)

Additionally Vitoconnect device don't provide any kind of log/error message to the user so the only way to find out what went wrong is to get someone from Viessman to take a look on that ....which is very unlikely (based on many threads in this forum). That may just lead to situation that Viessman will "break/ban on server" some Vitoconnect devices just to force user to buy new ones...which is just as ridiculous as it sounds.